Cisco IOS Config

From XMission Wiki
Jump to navigation Jump to search

If you are using an IOS based Cisco router for your DSL connection, this sample IOS configuration file should help you out.


ip subnet-zero
!
ip dhcp excluded-address 10.0.0.1
!--- the DHCP pool will not lease this address; it's used by ethernet interface
!
ip dhcp pool <pool name>
network 10.0.0.0 255.0.0.0
!--- you need to adjust this for your range of addresses
default-router 10.0.0.1
!--- default gateway will be assigned to local devices
!
interface FastEthernet0/0
!--- you may need to alter this interface name depending on hardware
ip address 10.0.0.1 255.0.0.0
!--- replace with your network address block
no ip directed-broadcast
no ip mroute-cache
! ip nat inside
! uncomment above if you want nat
!
interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/32
!--- pvc 0/32 is CenturyLink DMT default
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Dialer0
ip unnumbered Ethernet0
! remove above if you want nat
!ip address negotiated
!ip nat outside
! uncomment above two if you want nat
no ip directed-broadcast
encapsulation ppp
dialer pool 1
dialer-group 1
ppp pap sent-username <username> password <password>
!--- replace with xmission account user/pass
!
!ip nat inside source list 11 interface Dialer0 overload
!access-list 11 permit 10.0.0.0 0.0.0.255
! uncomment above for nat
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!